PDA

View Full Version : PSPHUGO: PC Engine Emulator for PSP v1.3.0 (CD MP3)



zx-81
May 29th, 2009, 17:02
http://zx81.zx81.free.fr/images/psphugo-snap-v101.jpg

Hi All,

For those who haven't seen previous version Hu-Go is a famous emulator
of NEC PC Engine console, running on many system such as Linux and Windows.
(see http://www.zeograd.com/ for details)

PSPHugo is a port on PSP of one latest version of Hu-Go.

What's new then in this version ?

- Audio Track support for CD-ROM
(support only MP3 format with stereo 16 bits samples
at 22k or 44k rate)
- CD-ROM TOC file format support.
- Using TurboRip, ripped CD can now be used directly with PSP-Hugo !
(see README file for explanations)
- Increase PSP clock speed when playing mp3 CD tracks
- Disable sound while saving states & screenshots
(to avoid scratchy noise for few seconds)
- Fix sleep mode issue
- Replace SDL sound engine by direct PSP audio stuff
to improve performances
- Fix issue when loading more than one CD image
- New backgrounds

How to use it ? Everything is in the README.txt file.

You may find here a version TurboRip to convert your original CD
to a format compatible with PSP-Hugo :
http://zx81.zx81.free.fr/public/win32TurboRipV100.rar

Please have a look to the README file to see how to proceed ...

CD Audio track reading is very CPU consuming, so if you run CD-rom games
with audio tracks, PSP-Hugo will automatically increase the clock frequency
while playing MP3 tracks to 300 Mhz. (You may modify this parameter in the settings menu).

Sources are included, and this package is under the GNU public licence v2
read COPYING.txt file for more information about it.

See http://zx81.zx81.free.fr/


Enjoy,

Zx.

Download and Give Feedback Via Comments

Dembonz
May 29th, 2009, 18:06
What an amazing suprise! Thanks again zx for your hard work and dedication to the psp scene. Your work is appreciated very much!

I never tried Dracula X on my psp with any PC-engine emu, but I think it's time I give it a shot :).

zx-81
May 29th, 2009, 18:40
thanks :). CD Audio support is not really accurate, so you may see delay between characters speaking and their voice :( ... It's good enough for beat them all like games, but may be not accurate enough for RPG

O-bake
May 29th, 2009, 19:48
Wow, a nice surprise indeed.

I thought this project was abandoned. I definately have to recharge my PSP. Haven't touched it this year, i guess.

Thank you.

wraggster
May 29th, 2009, 20:18
its always nice to see emulators get updated, as much as i like homebrew im an emulation fan more than any.

(pity that snes emulation on PSP is a dodo)

ac3knight
May 30th, 2009, 08:53
i've got a problem with turborip, whenever I run it i get the error:-

( 6) Error opening Registry for "Hardware\Devicemap\SCSI\ SCSI Port 0"
Error = 2
portNumber = 0

think its something to do with the CD ASPI (im using vista)?

any alternative solutions to automate conversion of CDs into iso/cue/mp3?

lxcainxl
May 31st, 2009, 06:18
Cannot load .TOC files, system crashes.

I am assuming that I am to load the whatever_game.toc file and not track02.iso.

I've ripped original CDs with TurboRip as specified. All Trackxx.iso / .mp3 files in same direcory as .toc under whatever_game sub-dir under "cd-roms" dir (.cue files too).

If I load .ISO file, some games do run, but no music.

Crashes every time I load the .TOC and I'm a complete loss how to work around this. Any ideas?

thx



(Running 4.05 M33-2 on psp-2000)

b8a
May 31st, 2009, 06:37
Thank you very much for continuning to work on this! I've only tried six CD games so far, but I've been very impressed at how they've run. This has got to be the best pce cd emulation on the psp so far. Unfortunately, it seems like the audio code is still a bit buggy. Most emulators have a problem with audio/visual syncing, but so far this one looks to be pretty far off on a consistent basis. And then, there are times where the CD audio continues while computer generated bgm is also playing... This is particularly annoying in Y's after the intro plays, and then the game starts... but the intro music continues to loop in the background behind the game music.

Also, there are some pretty heavy graphic glitches in the cut scenes in Lords of the Rising Sun.

But, honestly, thank you SO much for continuing your work on this emulator!

Smashed Brother
May 31st, 2009, 09:26
This update was quite a surprise... I was under the impression that this was no longer being worked on. But yeah, I'm having the same problem as the guy a few posts back. Whenever I try to load the .toc file, the emu just crashes to pieces. I've used both 'TocFixer' and 'TurboRip' to get as accurate an image as possible; I even used the .toc data off of the Necstasy site, but no luck. For the record, the only game that I tried was 'Seirei Senshi Spriggan'. If I load just the ISO, it works, but... no music :(

Well, I guess in the meantime, I'll just keep using the cumbersome-but-99.99%-perfect 'Yuna-swap trick' until I get this issue all figured out.

zx-81
May 31st, 2009, 20:36
i've got a problem with turborip, whenever I run it i get the error:-

( 6) Error opening Registry for "Hardware\Devicemap\SCSI\ SCSI Port 0"
Error = 2
portNumber = 0

think its something to do with the CD ASPI (im using vista)?

any alternative solutions to automate conversion of CDs into iso/cue/mp3?

i haven't tried turborip on vista because i don't own such "operating system" ... it seems it doesn't work :(.

TOC file should have the format generated by turbo rip with TurboRip.exe /PCEP /RS=22050 options.

Have a look in doc folder of the zip archive for an example. All audio tracks should have a name like :

01.mp3 if the track is the track number 1 in the TOC.



Thank you very much for continuning to work on this! I've only tried six CD games so far, but I've been very impressed at how they've run. This has got to be the best pce cd emulation on the psp so far. Unfortunately, it seems like the audio code is still a bit buggy. Most emulators have a problem with audio/visual syncing, but so far this one looks to be pretty far off on a consistent basis.

Yes, there is no synchronization between voice (cd audio track) and image, so you may encounter very strange issue ...



And then, there are times where the CD audio continues while computer generated bgm is also playing... This is particularly annoying in Y's after the intro plays, and then the game starts... but the intro music continues to loop in the background behind the game music.

that's strange i will have a look on this issue. I'm playing only one track at a time so it might be a bug in audio / music threads.



Also, there are some pretty heavy graphic glitches in the cut scenes in Lords of the Rising Sun.

But, honestly, thank you SO much for continuing your work on this emulator!

thanks for your feedback :)


This update was quite a surprise... I was under the impression that this was no longer being worked on. But yeah, I'm having the same problem as the guy a few posts back. Whenever I try to load the .toc file, the emu just crashes to pieces.

PSP Hugo support only toc files generated by TurboRip with the parameters /PCEP /RS=22050. Without those parameters, or without TurboRip it might just don't work.



I've used both 'TocFixer' and 'TurboRip' to get as accurate an image as possible; I even used the .toc data off of the Necstasy site, but no luck. For the record, the only game that I tried was 'Seirei Senshi Spriggan'. If I load just the ISO, it works, but... no music :(

Well, I guess in the meantime, I'll just keep using the cumbersome-but-99.99%-perfect 'Yuna-swap trick' until I get this issue all figured out.

90% of the games i've tried are working fine using TurboRip with /PCEP /RS=22050

B2K24
May 31st, 2009, 20:49
Thank you so much ZX for this update. I'm very happy you got the audio worked out for this cd emulation. I very much appreciate your work on all your softwares.

Just like the readme says mount bin/cue or iso/wav/cue with virtual cd tool then execute Turborip with these parameters
TurboRip.exe /PCEP /RS=22050
works perfectly on winXP SP2

I think with vista and windows 7 they have different or incompatible ASPI manager or support
can anyone confirm if this is the case?
You guys can always vmware XP from within vista/7 to execute perhaps.

Very nice work ZX, most impressive. I'm so happy to be able to play PCE-CD on a portable it's amazing. Everything working flawlessly here so far. Thank You :)

harvin07
May 31st, 2009, 20:53
o

lxcainxl
May 31st, 2009, 22:48
PSP Hugo support only toc files generated by TurboRip with the parameters /PCEP /RS=22050. Without those parameters, or without TurboRip it might just don't work.

90% of the games i've tried are working fine using TurboRip with /PCEP /RS=22050

Will double check on the /PCEP /RS=22050 switches. Man, if so, I've gotta re-rip all my CDs.

Wish me luck!

zx-81
June 1st, 2009, 17:37
good luck ... you can still rip your CD using Nero with MP3 encoding (using 22050 with 16 bits samples) with %N.%E for filename creation method.

Then using ImgBurn you can still display the TOC of the CD and using notepad++ (or any text editor) write manually your TOC file ...

Smashed Brother
June 1st, 2009, 20:07
Well, I used the cmd line that you provided for TurboRip and voila! Success!

Unfortunately, I had no music in 'Seirei Senshi Spriggan' and the other game that I tried, 'Beyond Shadowgate', had some music, but no voiceovers. Also, the gfx were supremely messed up, but I know that it's not the emu's fault because it was the same situation when I played it using the 'Yuna-swap'.

Maybe I'm missing a step along the way?

Apoklepz
June 2nd, 2009, 21:09
Dracula X and Fighting Street run fine for me and the playability of mp3 is a very, very nice addition. The only thing is that in-game sound is still bleeps and blops.

Thank you for this!

hcf
June 10th, 2009, 17:34
Great work ZX-81!!! I have tested some games and they work almost perfectly!! Big thanks for your effort!!!! I am extremely happy for the possibility of playing CD games in the PSP now with sound! :-)

As far as the "loop" bug is related, I think that I can put some light in the problem, as I have had a similar problem and I am almost sure about the reason.

The thing is that I am an amateur developer, and I have developed my own PC Engine games using HuC (it's a C compiler made by the people who made Hugo). Well, I have seen that the games made by me have that problem: the audio tracks loop, and it is really annoying!!. My games work perfectly in MagicEngine and Mednafen (both are PC emulators) but I think that psphugo has inherited a little bug that maybe was in the Hugo emulator too. I have read a bit of your code and I have tried to modify it to test my hypothesis, but sadly I am not able to compile it :-(

My hypothesis is the following: when I program a PC Engine game and I call the method to play a CD track, I can send 3 values to this method: MUTE, REPEAT and NORMAL (0,1,2). But if we see the source code of psphugo in the file mp3player.c, we see code like this:

if (isRepeatMode)

or

if ( !isRepeatMode)

In other words, psphugo is assuming that RepeatMode has only two values (0->Normal, 1->Repeat), but in my opinion, the PC Engine works with 3 valid values (MUTE, REPEAT, NORMAL).

In my opinion, this problem can be solved changing the if(!isRepeatMode) condition by the if( isRepeatMode == 0 || isRepeatMode == 2), and changing the if(isRepeatMode) by if(isRepeatMode == 1).

Sadly, I am not able to test it because I have not been able to compile the code, but I am willing to help to debug this problem, because fixing it, everybody will be able to play our homebrew games in the PSP with sound!!

If you want, let me know and I can even send you some of my games that can show this problem, or maybe if you can give me some clue about compiling the code, I can try to fix it myself and tell you if my hypothesis was right... or not.

Thank you very much again for your work. It's wonderful to find people like you developing both the PC Engine and the PSP scene!!! :-D

zx-81
June 10th, 2009, 22:35
Thanks for your feedback :)

In all psp_mp3_play_file function calls the repeat parameter is always 0 or 1 (not 2 :( ). we can discuss those issues on msn (have a look to your private message ;) )

hcf
June 11th, 2009, 09:52
Oh, I see that you are right, it seems that this issue can be at a lower level. Now I am a bit busy, but I will contact with you soon. I am very interested in helping to repair this point, as your emulator is the best thing that has happened to the PC Engine scene in a lot of time!! :-D
Big thanks again!!

beardude
July 1st, 2009, 13:39
When playing Yamato the intro music plays well but the opening menu music loops during gameplay.

sorandor
July 4th, 2009, 04:25
Im also having problems with turborip.

I mount my image with Daemon tools lite, i use vista, so i was aware of the probs. I grabbed a turborip which said works with vista. I then go into turborip and it puts it all in the folder having chosen my cd rom drive. But still when i load it up on my psp it just wont work.

I think the problem is i cannot set the parametres. I also read through the thread and tried to work it from the command prompt, but still i didnt even see any mention of parameters then (unlike when i just double click turborip). I did notice in turborip it didnt allow me to alter parameters.

Can anyone help me out here, as im desperate to play it came from the desert cd rom on my psp. Its been a heck of a long time since i played it on my ol amiga.

When i boot it up on my psp i try to load the toc it says load error (via hugo) i then try load the iso it just hangs on "just a moment".

Many thanks for any help guys.

Additionally i have the audio tracks appearing in mp3 format once i open the folder turborip has created.

zx-81
July 6th, 2009, 08:25
you can create a turborip shortcut to your desktop and add " /PCEP /RS=22050" to the command line field of this shortcut.

sorandor
July 6th, 2009, 19:13
Sorry to be new about this. But how do i add that line to the command line field of the shortcut? I made the shortcut as advised and then checked properties, but couldnt find where to add it.

Many thanks for your help on this