PDA

View Full Version : error compiling tiffsdk1.1



emitrom
October 25th, 2006, 14:06
Hello,

I was trying to get the psp-tiffsdk-v1.1 compiling and running on my pc but I have got into a few problems.

The examples from psp tutorials I can get to compile using cygwin/psptoolchain/pspsdk *but* when I unzip the tiff sdk 1.1 I get the following errors:

tiffsdk.c:215: error: conflicting types for 'sceKernelDelayThread'
/usr/local/pspdev/psp/sdk/include/pspthreadman.h:323: error: previous declaratio
n of 'sceKernelDelayThread' was here
make: *** [tiffsdk.o] Error 1

Apologies if this has already been covered but searched for another thread with this in and couldn't find one.

Any ideas as to what I am missing? Am I using the wrong pspsdk? (using beta2)?

TIA

MaBo1968
November 1st, 2006, 18:12
Hello,

change the line "void sceKernelDelayThread(SceUInt delay)" in tiffsdk.c to "int sceKernelDelayThread(SceUInt delay)".

Thats all !