PDA

View Full Version : Downgrading of v1.51/v1.52 PSPs to v1.5 !!



wraggster
August 28th, 2005, 22:30
Speculation is rife about a rumour that Yoshihiro and Team Wab have somehow worked out a way to downgrade the as yet non homebrew PSP consoles to v1.5 so in other words we may yet see some very exciting news :)

I will as soon as i chat to Yoshiihiro and get more information get back to you but i trust both him and team wab so this could be the news we have all been waiting for.

MaverickHunterX
August 28th, 2005, 22:57
Man...heh, I figured they'd find an exploit for 2.0 before this....

So many people were advising to just upgrade to 2.0 as 1.51 and 1.52 would be skipped...

Yet another mistake in my dealing with this system...

Can't wait to unlock the potential of this device..good find tho! :)

D-Boy
August 28th, 2005, 23:04
If this is true then that's great news would be better to bring it down to 1.0 but still very nice ;) I'm guessing it will be for the american versions and not the japanese but hopfully that will come along also.

Predator_1991
August 28th, 2005, 23:16
everyone said (on forums) that if you have 1.5X you should upgrade to 2.00
. so i upgraded my 1.52 :'( , is there going to be a downgrade for 2.00 too?
plz plz plz plz plz plz

Meshyf
August 29th, 2005, 01:27
Wow that was fast.

urherenow
August 29th, 2005, 02:38
Sorry, but I have to be a skeptic on this one. If you can get an update to even LOAD from a 1.51 or 1.52, for you to be ABLE to downgrade, then you could also get the homebrew to run and the whole thing would be pointless. This is unless they could simply hack an official 1.50 update file to think it's a 2.0 or whatever, and hacking it won't ruin the workings of the digital signature...


But again, in this case, it would end up still working for a 2.0 as well, but they only say 1.51 and 1.52?.... something smells fishy :confused:

WSOUNitePirate895
August 29th, 2005, 02:56
from pspupdates.com, psp-spot

"Downgrade 1.5x to 1.50?!
Yoshihiro from Team Wab just revealed that he managed to downgrade 1.5x PSPs back to 1.50. He will release the method on September, 1st. w00t! Yoshihiro has stated that the reason for the delayed release is that the program is still buggy, and there is still a risk of bricking the PSP. For those of you who have upgraded to 1.51 or 1.52, or never had the chance to play homebrew before, stay tuned!"

Shannon
August 29th, 2005, 04:02
Hmmmm downgrade at the risk of bricking your PSP....

Nice they are doing this, but ultimately the answer is just fooling newer titles into thinking you have whatever version they are looking for.

But at least it increases the number of PSP's where you can run homebrew.

shadowprophet
August 29th, 2005, 04:12
Ive got a 1.5. But somday it'll give out.
Sony didnt build those to last forever:p
I hope this turns out to be true, that way, Somday when I finely have to get another psp, I'lll know I can still play my homebrew:p
Cross your fingers ppl :D

YourStillWithMe
August 29th, 2005, 04:28
I mean no disrespect to Yoshiro and team WAB whats so ever but if they can figure out a way to run a program in 1.51 and 1.52 why in the hell dont they just explain how they did it or create a program to run other programs on it? (hence homebrew) I feel the same as WSOUNitePirate895. . . .Besides there is the risk of F***ing up your PSP. I don't know about you, but if I had a 1.51 or .52 I would not try this out and risk losing 260+ dollars. Would you?

I think that people should focus on the 2.0 version right now because the update file has been decrypted and, they've already found some way of running homebrew through the offline portal, someone figured out how to get past the loading screen and run a program by tricking the system into thinking it was an update, and also someone figured out what kinds of files the psps ver firmware 2.00 recognizes. Plus, in the future were probably going to have to upgrade to 2.0 in the next month or so when newer games come out. (possibly GTA and Medievil for example) Just think about it Sony also has the White PSP that's going to be a version 2.00 coming out. Wouldn't that be more logical?

Kaiser
August 29th, 2005, 06:44
Of course cracking 2.0 would be the logical next step. The fact remains more people have 1.5X then 2.0's. Just take one victory at a time and be happy for the PSP scene. This is a major victory and as we learn more about the PSP and its firmware we can develop greater games and emulators.

one step at a time my friends :)

Fetty
August 29th, 2005, 07:22
first of all to all those worried about bricking your psp it can be sent to $ony and they will fix it for a relatively nominal fee and those saying hey if they can downgrade why not run homebrew natively... the process to downgrade may not be as simple as running homebrew code but as someone earlier posted hacking a valid update file and changing it to register as the 2.0 update which would also explain why it wouldn't work for 2.0 psps it would take a different manner of hacking to force a 2.0 to "upgrade" to a firmware it knows to be the same or lower than its current version... that and 2.0 doesn't have the same encryption as 1.51/2 particulary the newest us 2.0 version

BigDaddyXD
August 29th, 2005, 07:45
Do you really think Sony will repair your PSP if you bricked it by trying to "hack" it?!
Thats like Intel sending you a new CPU because your old one burnt the shit out
because you overclocked it by factor 2...
I dunno, is this a personal experience of you or have you "heard" of it?

Shiaoran
August 29th, 2005, 13:20
awww... i wanted to sell my 1.5 for a small fortune... >:D *evil laught*

Mental2k
August 29th, 2005, 13:37
BigDaddy, of course they'll fix it, they'll charge you but they'll fix it. You've broken the warranty, but sony still want your money. This probably jus tricks your psp into thinking the v1.5 is actually a v2 update. Sony could prob easily fix this issue. fus reflash you psp.

BigDaddyXD
August 29th, 2005, 15:56
They shall give me the tools they use... Well... no, they don't have to...
I only want the code... YES, THE code.... that verifies the "Verified"-Games...

alepus
August 29th, 2005, 16:27
I think that people should focus on the 2.0 version right now because the update file has been decrypted and, they've already found some way of running homebrew through the offline portal, someone figured out how to get past the loading screen and run a program by tricking the system into thinking it was an update, and also someone figured out what kinds of files the psps ver firmware 2.00 recognizes. Plus, in the future were probably going to have to upgrade to 2.0 in the next month or so when newer games come out. (possibly GTA and Medievil for example) Just think about it Sony also has the White PSP that's going to be a version 2.00 coming out. Wouldn't that be more logical?


future games will probably require 2.0 to run and that is why WAB team created the program called "Wab Version Changer V2".
so that you can trick the psp in thinking that it has been updated and ALL games will run.

aight!?

I have a psp 1.50 but i'm still really happy for the scene due from this achievement. being able to downgrade from 1.5x to 1.50 is ****ing awsome!
i'm sorry for you lame ass who upgraded your psp to 2.0 and cant be happy for those who hoped and waited!

and play some frickin games from an offline portal? i'll rather keep my 1.5 and load them from the stick.

YourStillWithMe
August 29th, 2005, 20:11
alepus-I have a 1.5 as well with a 1GB memory stick full of plenty of roms and such. . . and I have a 2.0 that I sold to my brother with a 32MB stick so either way; in terms of updates that come with games, i'm ok. If I just buy a new game i'll switch with him because he just loves Tiger Woods. (As do I)

I'm in NO rush to update!

Mental2k
August 30th, 2005, 00:00
They shall give me the tools they use... Well... no, they don't have to...
I only want the code... YES, THE code.... that verifies the "Verified"-Games...


Where did anyone say sony would release the code, dont't emmbarrass yourself, sony would fix it, but will charge.

The updater would be hacked, not with any sony permission, they'll just hack it. Reverse engineer it. If they do the updater will be illegal, but no matter they'll show up on ftp and torrent. probably in the same way that xbox-scene has xbins.

MaverickHunterX
August 30th, 2005, 00:25
With concern to returning the PSP...heh, the whole process shows the illegitimacy of Sony's threats...

Returns are dealt with at the local level initially, as in the local Joe at your Wal-Mart. So, if your PSP say has a crack right through the screen (intentionally or not) they will instantly give you a new one and send it back to Sony who has there own local Joe working in the f-ed up PSP department. It's only if the head honcho says their doing a random check, even then the process to track YOU down and place any sort of lawsuit is virtually impossible.
If I pay 250 for a system, its mine; open, closed or covered in shit.

Mental2k
August 30th, 2005, 00:38
They wouldnt press chages against the user they'd do i against the writer. It's the distribution of a hacked updater they'd have the issue with not the fact you have one on your PSP. Basicly, if it is a hacked updater, my guess is that a patcher will be released for the v2.0 updater, which will replace the contents of the patcher with the contents of the v1.5 updater. None of which would be illegal.

So you'll probably need to download the v2.0 updater, the v1.5 updater and the downgrader program. Then you'll probably run the downgader and it'll take parts from the v1.5 and put them into the v2.0. Effectively turning the v2.0 updater into a v1.5 updater, but still making PSP think that it is a v2.0 updater.

Then when you run the v2.0 updater it'll actually downgrade your PSP to v1.5.

This may be totally waaaay ff but i reckon this'll be how it works.

Thus at no stage is it illegal, and easily distributable on every reputable site.

Farcicalname
August 30th, 2005, 07:55
So this is separate from the program that'll let you pretend you have whatever firmware?

YourStillWithMe
August 30th, 2005, 19:33
Not to change subjects but this kidn of goes along with what firefox said does the WAB version cahnger work with the games? Do you bypass the updates that are with the games? I CANT find out if this works. I've only heard from one person and i need a little bit more confirmation. I got the program to work to change to 1.52, 2.0 and 1.00 etc. etc. but does it work when the games are inserted? please post

ataribob
August 30th, 2005, 19:49
Funny I don't see any games comming out from Sony yet to cause me to upgrade.

Could be after I get done playing some translated Snes Rpg's games.
2 years worth .


Wonder what update will they be on then #15 ??

Tomppa
August 31st, 2005, 17:52
Does all of the lauch games work with 1.52? If so I'm not going to upgrade for a Looong time.. Btw, what is the difference beetween 1.0-1.52 except the homebrew=no thing?

ataribob
September 1st, 2005, 00:25
Darkstalkers Chronicle: The Chaos Tower
Dynasty Warriors
Gretzky NHL
Twisted Metal: Head-On

These 4 work without an upgrade on 1.50
I don't have any more to test

chrisvenn
September 1st, 2005, 13:14
Ridge Racer and Tony hawks work on 1.52

F34R
September 1st, 2005, 14:45
Ridge Racer and Tony hawks work on 1.52\

... and why wouldnt they ? Games released previously to the 1.51/.52/2.0 updates will work on ANY version PSP. Its the games that are newly released that "require" an updated firmware version.

chrisvenn
September 1st, 2005, 16:27
\

... and why wouldnt they ? Games released previously to the 1.51/.52/2.0 updates will work on ANY version PSP. Its the games that are newly released that "require" an updated firmware version.

Ok i will add to my comment.....

Ridge racer and tony hawk UK versions work on v1.52

They are newly released they came out today in the UK so thats why i added them to his list.

seanj72
September 1st, 2005, 16:31
Hi

I never believed this when i heard about this but when i tried it myself, it was so easy. You just need to complete one free offer then cancel it before it starts to cost, then refer friends to do the same! Do not bother spending hundreds on the new consoles when this is free. The site is. . .

. . . REMOVED, 'cause we don't like spam posts like these!

chrisvenn
September 1st, 2005, 16:33
Hi

I never believed this when i heard about this but when i tried it myself, it was so easy. You just need to complete one free offer then cancel it before it starts to cost, then refer friends to do the same! Do not bother spending hundreds on the new consoles when this is free. The site is. . .
http://www.consolegrab.co.uk/


SPAM!!!!

zeadlots
September 1st, 2005, 18:41
What is the status of this release to downgrade 1.5X machines? I will be running off to the local EB to pick up a psp and I'm sure it will be a higher version than 1.5

The previous news says that WAB will be releasing the downgrade utility today (sept 1). Has anyone seen this? I know the day is not over yet.

alepus
September 1st, 2005, 20:10
hehe. here is a little "bonus" from WAB for those who are waiting for the downgrade.

http://www.wab.com/

zeadlots
September 1st, 2005, 21:47
Thanks for the photo's. If I ever see you two, your getting a hand shake and a wiskey.

Waiting patienly, Glad to see that they are aware we are waiting and I for 1 really appreciate when people give updates, useless or not.

:D