UAE4All works well on raspberry Pi2 (thank you, it's great !), with an USB Joypad.
It seems the working button for fire is the index 2 (zero-based index), determined with the "jstest" linux command (for example "jstest /dev/input/js0").

But I now use a real Amiga Joystick with a DB9 to USB converter, and the fire button is detected as the button index 0 :

Axes: 0: 0 1: 0 Buttons: 0: on 1: off 2: off 3: off 4: off 5: off 6: off 7: off
Fire button works in EmulationStation menus, but it isn't detected at all in UAE4ALL Amiga Games (Dynablaster, Pang, Battle Squadron).

My question is : how could I make the fire button 0 working in UAE4ALL ?
- is it possible to map the button 0 to button 2 in the Linux layer ? (already done in retroarch, but config is UAE4ALL independant).
- would the solution be to modify the UAE4ALL code to make the button 0 to be copied to button 2 (in the bit mask in "od-joy.cpp") ?
- I don't know if I could do a DB9 to DB9 adapter since the third button seems to be a little bit special (I am not allowed to post a link, see "DB9 amiga joystick" first answer on Google). And I would prefer to find a software solution.
- or is this a planned evolution or a known bug in UAE4ALL ?

Config :
- Raspberry Pi 2
- Retropie 3.0
- Retronic design DB9 to USB joystick converter
- Amiga single button joysticks : ZipStick, Speed King

For information, the button 0 works fine in WinUAE on Windows. So detecting the button 0 does not seems to be abnormal.
I contacted the adaptator supplier, which told me he respected the USB HID standard.

Thank you for any help !