The Flow is the god of the PSVita Hacking scene and with that it looks like HENkaku/taiHEN (with Ensō) for PlayStation Vita v3.65 will soon be here, heres the info:

The PlayStation Vita Scene is finally moving forward from the v3.60 standard, but sadly you can't yet install it directly on newer firmwares.
What do we know right now and what will get get?

A couple of hours ago, TheFlow told us that he was able to find the offsets to run HENkaku Ensō on firmware 3.65 thanks to @Mathieulhs devkit. After finding the offsets, TheFlow took a leap of faith and ran the Ensō code on his PSTV which fortunately, booted up into firmware 3.65 with HENkaku enabled!

This means that TheFlow has successfully ported Ensō to firmware 3.65 and youll be able to enjoy games that require firmware 3.61-3.65 (not the 3.67) pretty soon IF YOU HAVE A PSVITA CURRENTLY RUNNING FW 3.60.

As TheFlow decided not to release the actual exploit chain, presumably so that Sony cant patch it for higher FWs, this hack will work like some earlier PSP CFWs in which some firmware modules are written before reboot. As a result of this, you wont be able to hack consoles that are currently running FW 3.61-3.65 just yet.

TheFlow has also cautioned against reinstalling the 3.65 PUP (firmware file) or erasing HENkaku when using this hack. Both these things cant be done by accident through normal usage so regular users will be safe.

What should I do and not do?

Right now, this is what you should or shouldnt be doing:

  • If youre on firmware 3.60, dont update to firmware 3.65 (or 3.61-3.67 for that matter)
  • If youre on firmware 3.61-3.65, dont update further. The lower the firmware, the better your chances of getting a hack are.
  • If youre on firmware 3.60, stay there. Lower firmwares should preferably be updated to FW 3.60 via the DNS method if you want to hack your device.

Right now, all you can do is wait a little. TheFlow has promised a release by the end of March and is already accepting bubble designs for the CFW updater bubble hell be releasing for FW 3.60 soon.