Page 1 of 6 12345 ... LastLast
Results 1 to 10 of 54

Thread: Grand Theft Auto : Liberty City Stories On Firmware V2.00

                  
   
  1. #1
    Won Hung Lo wraggster's Avatar
    Join Date
    Apr 2003
    Location
    Nottingham, England
    Age
    46
    Posts
    122,985
    Blog Entries
    3209
    Rep Power
    50

    Default Grand Theft Auto : Liberty City Stories On Firmware V2.00



    Grand Theft Auto : Liberty City Stories is confirmed by several sources close to me that it works on PSP v2.0 firmware and above only.

    Unlike other PSP Sites that promote warez by mentioning certain software we dont, the best way to play Grand Theft Auto : Liberty City Stories is by buying from a reputable site like Lik Sang.

    As you know this is the killer game for PSP and even if you do upgrade to v2.0 then Fanjitas Eboot Loader plays a lot of homebrew for the PSP, check out the details here -> http://www.dcemu.co.uk/vbulletin/showthread.php?t=12797

    Post your reviews of Grand Theft Auto : Liberty City Stories in our PSP Review forum.

  2. #2
    DCEmu Old Pro xuphorz's Avatar
    Join Date
    Jun 2005
    Location
    USA
    Age
    29
    Posts
    1,193
    Rep Power
    50

    Default

    WAB version changer works for SSX: On Tour, and that requires 2.00 also, so shouldn't it work for this?

  3. #3
    DCEmu Pro vincesecuricor2005's Avatar
    Join Date
    Oct 2005
    Location
    Kent, England.
    Age
    31
    Posts
    534
    Rep Power
    47

    Default

    oh all my dreams of a life of gta and homebrew are crashing right before my eyes this sucks

  4. #4
    DCEmu Old Pro xuphorz's Avatar
    Join Date
    Jun 2005
    Location
    USA
    Age
    29
    Posts
    1,193
    Rep Power
    50

    Default

    use wab changer, sum1 just tried it for me, it works

  5. #5
    DCEmu Pro vincesecuricor2005's Avatar
    Join Date
    Oct 2005
    Location
    Kent, England.
    Age
    31
    Posts
    534
    Rep Power
    47

    Default

    i thought that the wabchanger had been tried and failed due to the new video codec needed by gta that is on v2.00 only????

  6. #6
    DCEmu Rookie
    Join Date
    Sep 2005
    Posts
    147
    Rep Power
    45

    Default

    I'm going to post this before any more idiots like xuphorz post their "success" in loading GTA WITHOUT installing a legit 2.0 fw:
    ----------------------------------------

    Now the Update:
    As many of you know, GTA:LCS was came out today to some parts of the world.
    Following the store release, a .iso popped up on numerous peer-2-peer sites.

    We are hearing many different ways to boot this .iso file, which is 455 MB RAR'd / 1.16 GB Unpacked. Naoneo has been kind enough to shay his thoughts with us:

    According to Naoneo (who has a reputation for knowing what he's talking about)

    "As it stands i've taken the better part of the past 5 hours analysing things, testing various methods for both my retail umd and my on personal iso dump, and i've come to the following conclusion.
    GTA:LCS REQUIRES the v2.00 firmware to operate, both the eboot and prx's are encoded in v2.00 fashion, this means that no ammount of file swapping or 'patching' of the boot.bin, far short of recompiling the original sources from scratch, is going to make a shred of difference, because the v1.50 firmware simply cannot execute or run v2.00 encypted data.

    This leaves only 2 possible choices :
    Upgrade to 2.00 and play the retail game
    Someone (im looking at you humma), gets firmware loading nailed down solid, allowing the complete v2.00 firmware to be loaded up with the umd, or iso set in memory to load, it will then execute from either umd or iso without any issues.

    This is far more than just differently encoded video or audio files, every bit of the code has been compiled and encoded for the v2.00 firmware, and as such until a way to successfully load the v2.00 firmware without issue arrives, only those owning a v2.00 psp and a legitimate copy of the game, will be able to play GTA:LCS.

    Great work sony, i must say."


    In other words, this is not a codec issue. (proven by people who have put the music/videos into other iso's and report them working fine)

    Also it is being reported that version changers do NOT work (for running the game off UMD). You must actually update your firmware to 2.0 (not 2.01)

    According to naoneo in regard to gtalc fix.rar
    Originally Posted by naoneo
    "The file matches the original eboot.bin byte for byte, its fake, just aimed at getting people clicking his lame assed refferal url's in the readme."

    Source: Naoneo (Maxconsole)

  7. #7
    DCEmu Pro vincesecuricor2005's Avatar
    Join Date
    Oct 2005
    Location
    Kent, England.
    Age
    31
    Posts
    534
    Rep Power
    47

    Default

    come on man aint no need to be calling peeps idiots you could have made your point without the assy comments

  8. #8
    DCEmu Rookie
    Join Date
    Sep 2005
    Posts
    147
    Rep Power
    45

    Default

    My bad, guess I got caught up from reading sooooo many of these "i got it to work" topics. My apologies

  9. #9
    DCEmu Pro vincesecuricor2005's Avatar
    Join Date
    Oct 2005
    Location
    Kent, England.
    Age
    31
    Posts
    534
    Rep Power
    47

    Default

    it is really eating me up though, which too choose?

  10. #10

    Exclamation GTA: LCS Custom Radio Station???

    Has anybody figured out how to make their custom radio station on LCS yet? It doesn't confirm it in the book and its not picking up my mp3s in the music folder. Is there a certain way to do it? Please tell!!!

Page 1 of 6 12345 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •