Valentines Day
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: More Info about the New 2.5 Exploit

                  
   
  1. #1
    Won Hung Lo wraggster's Avatar
    Join Date
    Apr 2003
    Location
    Nottingham, England
    Age
    48
    Posts
    128,362
    Blog Entries
    3209
    Rep Power
    50

    Question More Info about the New 2.5 Exploit

    Heres more details, make of them what you will:

    OK to end fear of the Exploit Here are the inner workings

    Tradional PBP and SAVEGAME Layout
    -ULUS100xxxx or EBOOT
    --Param.SFO (tells how the psp handles the file: e.g. title - update ver. 2.51)
    --icon0.PNG (icon)
    --icon1.PMF (almost like a short movie clip <500kb
    --pic1.PNG (background for pile that appears when you look at the file)
    --SND0 (background sound-not in most saves or EBOOTs)
    --Data file/data.psp (name vary depending on game saves...data.psp is the name when in eboots)
    --Data.psar(only in eboots)

    Well my Exploit contains...
    --Param.SFO (tells how the psp handles the file: e.g. title - update ver. 2.51)
    --icon0.PNG (icon-overflow.tif)
    --icon1.PMF (blank PMF found in iso rip kits)
    --pic1.PNG (background for file-framebuffer)
    --SND0.AT3 ( small randow sound clip)
    --Data file/data.psp (from v1.5)
    --Data.psar(from v1.5)
    and...
    --Pic0.PNG (overflow.tif)

    My Original Idea For The Exploit
    1)the icon0 would be set to the overflow.tif
    2)pic1 the framebuffer image
    3)the 2 data files as 1.50s data files
    4)SND0.AT3 a music file >20mb
    5)ICON1 the blank pmf found in iso rip kits
    6)Param file set to be read as updater version 2.51
    7)pic0 overflow.tif resized to 272x480

    Only one thing from my original blueprint wasn't used : the AT3 file is 5kb

    How This Works
    This works by overloading the psp audio with a glitch sound, and overloading the image handler with overflow.tif, thus in conjuction overriding the TIF patch.

    Does that mean much to you ?

  2. #2
    DCEmu Newbie Insane1's Avatar
    Join Date
    Oct 2005
    Location
    Wolcott, CT
    Age
    31
    Posts
    98
    Rep Power
    0

    Default

    So...overloading two things to allow for the exploit?

  3. #3
    DCEmu Pro vincesecuricor2005's Avatar
    Join Date
    Oct 2005
    Location
    Kent, England.
    Age
    32
    Posts
    534
    Rep Power
    53

    Default

    ok so this basically sets the path for a downgrader pretty cool, and well appreciated but what im personally lookin for is havin homebrew etc.... livin in harmony with the latest f/w versions, still job well done though geezers

  4. #4

    Default

    here fw 3.00
    http://s47.yousendit.com/d.aspx?id=1...D3N2360G24AWMK

    sry..... don't blame.......

  5. #5
    DCEmu Legend
    Join Date
    Sep 2005
    Posts
    2,355
    Rep Power
    61

    Default

    What does this file have to do with anything? This is the second time you have posted this file that I have seen, again with the 'do not blame' message. Just because you are 14 doesn't exonerate you from all harm. Unless you have personally tried this file on your PSP, do not upload it here...

    Had you worked hard to buy your PSP rather than get it from mommy you'd have a little more sense than to be sharing links to files that no one has any clue about that could essentially ruin their PSPs...

    Anyway, back on topic, I hope to hear some more news of this soon. Not that I'd ever upgrade to 2.50, but it would be great to have all our doors open in other firmwares.

  6. #6
    DCEmu Pro vincesecuricor2005's Avatar
    Join Date
    Oct 2005
    Location
    Kent, England.
    Age
    32
    Posts
    534
    Rep Power
    53

    Default

    and hopefully not jus for downgradin

  7. #7
    DCEmu Pro YourStillWithMe's Avatar
    Join Date
    Jun 2005
    Location
    C.T
    Age
    31
    Posts
    724
    Rep Power
    55

    Post

    I appreciate what is being done but we don't need a downgrader. We have to try to keep up with these stupid firmware updates I know were gonna have to update sooner or later. . . . .

  8. #8
    DCEmu Rookie
    Join Date
    Sep 2005
    Posts
    137
    Rep Power
    51

    Default

    well until they release a firmware with a new feature that can be exploited as much as we need for homebrew, i would say a downgrader is exactly what we need

  9. #9
    DCEmu Pro vincesecuricor2005's Avatar
    Join Date
    Oct 2005
    Location
    Kent, England.
    Age
    32
    Posts
    534
    Rep Power
    53

    Default

    agreed i dont wanna have to keep up/down grading all the time it feels too dodgy id rather have my cake and eat it lol

  10. #10
    DCEmu Legend
    Join Date
    Sep 2005
    Posts
    2,355
    Rep Power
    61

    Default

    Having downgraders that work are a plus though. For people buying a new PSP having the ability to downgrade it makes it much better for them in the long run. Granted I want to be able to run homebrew like I can on my 1.0 on all firmwares, but that wont happen anytime soon.

    2.0 is getting much better homebrew development and will probably remain that way for some time. But for those who buy PSPs now, that are shipping with 2.50 it would be nice to get back to 2.0 and be able play homebrew and some of the newer games.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •