Valentines Day
Page 5 of 17 FirstFirst 12345678915 ... LastLast
Results 41 to 50 of 166

Thread: NEOGEO/AES Tests

  1. #41
    DCEmu Newbie
    Join Date
    Dec 2005
    Rep Power


    Quote Originally Posted by quzar
    The problem is that each version of MAME uses different romsets, gneogeo depends on dat files, and nebula ususally depends on the newest mame definitions.
    Nebula uses external dat files, and there are lots and lots of them about
    (plus you can make your own) which confuses things even more . . .

    if decrypted (non-encrypted) sets are what's required -

    (this is for the layman not Quazar)

    download WinKawaks ( Kawaks 1.55 is the latest) load the standard MAME set with 'Enable save decrypted Cs after loading' selected in the Tools menu.

    load the game, wait a moment for it to start the attract mode or what ever, pause and close the emu.

    open the Winkawaks folder and there will be a load of decrypted C roms in there plus a new S rom, use these instead of the original encrypted Cs

    it doesn't help with encrypted Ps or Vs which occur on later games,
    but there are other tools around which will handle that.

    example -

    game (
    name mslug3d
    description "METALSLUG 3 (decrypted)"
    cloneof mslug3
    romof mslug3
    rom ( name ms3n_c1.rom size 8388608 crc 3540398c )
    rom ( name ms3n_c2.rom size 8388608 crc bdd220f0 )
    rom ( name ms3n_c3.rom size 8388608 crc bfaade82 )
    rom ( name ms3n_c4.rom size 8388608 crc 1463add6 )
    rom ( name ms3n_c5.rom size 8388608 crc 48ca7f28 )
    rom ( name ms3n_c6.rom size 8388608 crc 806eb36f )
    rom ( name ms3n_c7.rom size 8388608 crc 9395b809 )
    rom ( name ms3n_c8.rom size 8388608 crc a369f9d4 )
    rom ( name ms3n_s1.rom size 524288 crc 2628d663 )

    the non-encrypted Ps from set mslug3n would be added to this along with the V roms and the M rom giving a fully decrypted set.

    PS. for mslug 3 there is actually a 128KB S rom that will work crc 8458fff9 (this set with the 128KB S rom will work in NeorageX which only supports 128KB S roms) but the 512KB rom is more correct but i don't know if you'll get that out of WinKawaks, its not the tool i use.

    this is just an example as to how to construct one fully decrypted set from a MAME rom set

  2. #42
    DCEmu Regular M Dash's Avatar
    Join Date
    Nov 2005
    Internetus Exploratis
    Rep Power

    Thumbs down Help Plz???

    Quote Originally Posted by M Dash
    ok, so I downloaded the ROM and compared with mine (, and the other one I have have different p1 & m1 files.

    so I renamed the plus ROM files, and tried to convert it again, and AGAIN I got this error / log:

    --- svcplus ---
    svc_p1.rom [--------------------------------------------------------------]
    svc_p1.rom [
    svc_s1.rom [--------------------------------------------------------------]
    svc_s1.rom [
    svc-m1.rom [--------------------------------------------------------------]
    svc-m1.rom [
    svc-v1.rom [--------------------------------------------------------------]
    svc-v1.rom [
    svc-v2.rom [--------------------------------------------------------------]
    svc-v2.rom [
    svc-v3.rom [--------------------------------------------------------------]
    svc-v3.rom [
    svc-v4.rom [--------------------------------------------------------------]
    svc-v4.rom [
    svc_c1.rom [--------------------------------------------------------------]
    svc_c1.rom [
    svc_c2.rom [--------------------------------------------------------------]
    svc_c2.rom [
    svc_c3.rom [--------------------------------------------------------------]
    svc_c3.rom [
    svc_c4.rom [--------------------------------------------------------------]
    svc_c4.rom [
    svc_c5.rom [--------------------------------------------------------------]
    svc_c5.rom [
    svc_c6.rom [--------------------------------------------------------------]
    svc_c6.rom [
    svc_c7.rom [--------------------------------------------------------------]
    svc_c7.rom [
    svc_c8.rom [--------------------------------------------------------------]
    svc_c8.rom [

    Save as 'svcplus.aes' ...

    CPU = 6144 KBytes, chksum=0x32A9639E

    BIOS = 128 KBytes, chksum=0x17B6D5F

    SFIXG = 128 KBytes, chksum=0x7E7E12

    SFIXB = 128 KBytes, chksum=0xD1B967

    SM1 = 256 KBytes, chksum=0x608EC8

    SOUND1 = 16384 KBytes, chksum=0x600E4DCC


    GFX = 65536 KBytes, chksum=0x23B4C5E4

    NG_LO = 64 KBytes, chksum=0xBE8040

    FUSAB = 4 KBytes, chksum=0x7A076

    FUSAG = 4 KBytes, chksum=0x8A0A6

    PEN = 512 KBytes, chksum=0x37488

    ERROR -10 !!!!!"

    I checked the other log and this one, and looks like the checksum on the CPU and SM1 got fixed:

    Before: chksum=0x32A96B7A
    Now: chksum=0x32A9639E

    Before: chksum=0x5664CB
    Now: chksum=0x608EC8

    This was the only checksum errors that I think they're now fixed... but still: why does the converter still give me the ERROR 10 message?? :\

    chui, can u plz check if still there are checksum errors? and help me with this error 10 thingy?? tnx in advance!

    ok, so i made this little Explorer trick, and i was able to: before the converter deletes the AES, i get the AES being used, so the program could not delete the file, and closed, leaving the file.

    i tried the convertion on the Windows version and i got some problems:

    - the BIOS graphics where corrupt, along with some of the game GFX as well, not to mention that the letters of the game menu, and everything else like life bar, power bar and any letter, don't appear. :\
    - I can't select the character i wanna play with.
    - some sound glitches... don't know if it's from the emu or from my PC slowdown...

    Someone help plz??? :\

  3. #43
    DCEmu Newbie
    Join Date
    Dec 2005
    Rep Power


    OK, I've checked my bios file sizes against Warmtoe's list too. They are correct. My only conclusion is that I've got a bad romset. I'll try others and report my findings.

    Shikigami: Check your PMs.

  4. #44
    PSP Coder
    Join Date
    May 2005
    Rep Power


    Tried only Shock trooper.

    Works ok, but i've used the Kawaks xbox romset, cause the mame one not working. I think it's a little slower than the real game, but it's wonderfull to see that on dreamcast !!! (And it's only an alpha !!!!)

    Only one problem, but that's not a bug, but an hidden request, my ps2 neo geo pad plugged in the DC with an adapter haven't the button in the good order !

    Thanks a lot for this release Chui !

  5. #45
    DCEmu Newbie mh777's Avatar
    Join Date
    Sep 2004
    Rep Power


    Tested the following, based on 15-20 minute playthroughs:

    Burning Fight: perfect w/sound on

    Magician Lord: good enough, music is screeching, sound FX and voices are fine, though

    Ninja Combat: same as Magician Lord

    Ninja Commando: (EDIT) with sound, it's perfect. However, there is no music.

    The Super Spy: a little slow, sound is similar to Magician Lord's

    Puzzle De Pon: tried it under the same conditions as Ninja Commando...same results as NC.

    Fatal Fury 2: a little slow with sound on (not too bad). Somehow, hit detection gets messed up in the second fight with the CPU (only throws can damage either player), and the fight timer lasts for two seconds in the third fight with the CPU, making it impossible to even get a round in.

    Samurai Shodown 2: a little slow at times. A player facing to the left will sometimes warp back to the right when running towards a right-facing player.

    Fatal Fury: good enough, save for the occasional warping problem as seen in SS2.

    Sengoku: almost perfect, save for a little slowdown and some very minor sound issues.

    NeoBomberman: good enough. No music.

    I'll edit this post with further tests if possible.

  6. #46
    DCEmu Newbie
    Join Date
    Nov 2005
    Rep Power


    Hi all, im test unibios in neo4all/aes and woks fine select mode console or mvs and works cheats ^^ good work chui!

    some shots

    ok next time test in my Dreamcast bye

  7. #47


    Now a simple question, how to burn?

    The windows version, not working to me

    The dreamcast version have 1st_read.bin and NEO4ALL folder

    How to burn a CD? with BIOS folder? with ROM folder? with PREFETCH folder? I try to burn in NERO MODE1 (all games without boot runs OK in this mode), with this files

    Neo4all (Folder)
    Bios (folder)
    Prefetch (Folder)
    Roms (Folder)

    nothing happened, I try to load the 1st_read.bin but mi DC can't respond

    I use DEMOMENU, and Utopia Boot, but nothing happened, please anyone can tell me how?

    Gracias ^^

  8. #48


    Quote Originally Posted by SUPNEO
    Hi all, im test unibios in neo4all/aes and woks fine select mode console or mvs and works cheats ^^ good work chui!

    some shots

    ok next time test in my Dreamcast bye
    OK - How!?!?!

  9. #49
    DCEmu Newbie
    Join Date
    Dec 2005
    Rep Power


    Some tests

    Ghost Pilots
    Stage 1 plays nearly perfect. To the end of the stage some flickering in the shadows of the clouds.
    Some strange sound behaviour as of Stage 2. A sound effect (don't know which one) plays uninterrupted one single tone.
    As of stage 3 the background music is missing. And as of stage 4 more sound effects are vanished (e.g. no sound of player's aircraft). The whole game becomes "silent" more and more but keeps playable all the time.

    Metal Slug X
    Lots of slow downs because of loading while playing. For short times (less than 1 sec) the game freezes because of the loading.

    Magical Drops 3
    Sound effects sounds "clanking". A few slow downs while loading. Despite of that the game stays playable all the time.

    View Point
    Plays perfect as I can see it. No strange behaviour in sound or gfx.

    Last Resort

  10. #50
    DCEmu Newbie
    Join Date
    Nov 2005
    Rep Power


    Quote Originally Posted by warmtoe
    OK - How!?!?!
    Hi all!

    renaming uni-bios.rom in to aes-bios.bin and put in bios directori and convert games.

    OK im tested uni-bios in my dreamcast and work but only work uni-bios 1.2 .

    Chui yea good work only a alpha but is good, chui the memory card in neo4all aes is not inplemented? uni-bios not save the config but works fine

Page 5 of 17 FirstFirst 12345678915 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts