If you upgraded to 3.0 to try it out and then downgraded back to 2.2.1 and now find your baseband stuck at 4.26, there is now a solution. Thanks goes to w1kedZ for all the help and for cracking those ramdisks!

This tool is based on the same exploit for the 5.08 bootloader, so you must have it. It will not work on 5.09 and so on. It will downgrade your baseband from 4.26 to 2.28! It is also very practical for you all that just upgraded to beta 4 to realize your sim adapter doesn't work with the newest baseband (4.26). We can downgrade your baseband to (4.22) so your sim adapter will function again.

I know most of you are wondering if you can downgrade the baseband to 2.28 and run 3.0 at the same time for the purposes of using yellowsnow. The answer is yes you can run 3.0 and the 2.28 baseband together but...