Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Monster Hunter Freedom Req 2.6 Firmware

                  
   
  1. #1
    DCEmu Newbie
    Join Date
    Apr 2006
    Posts
    2
    Rep Power
    0

    psp Monster Hunter Freedom Req 2.6 Firmware

    I think some of you might be wondering about the firmware requirements for mhf. Well, i took the risk and got the game knowing it might require 2.7 and if it did, i would update. cuhz wen i heard about monster hunter for psp, i got a psp right away, so i would do nething to play it. =p

    but newayz it requires 2.6 firmware. so im happy.
    hope i helped those who were wondering.

  2. #2
    Banned vettacossx's Avatar
    Join Date
    Nov 2005
    Location
    UPSTATE NY..USA DCemu Modders UNITE ;)
    Posts
    892
    Rep Power
    0

    Default

    thanks for the news sirbrianx im sure this will help sell the game to more homebrew gamers seems 2.6 can run homebrew as well im going to add this RPG to my collection ...

  3. #3
    DCEmu Newbie
    Join Date
    Mar 2006
    Posts
    50
    Rep Power
    0

    Default

    playable on 1.5, confirmed by myself, only in iso form (I do have the original) umd kept messing up on me but possible for some others to get it working.

  4. #4
    DCEmu Old Pro mr_nick666's Avatar
    Join Date
    Mar 2006
    Location
    Bideford, Devon, UK
    Age
    40
    Posts
    1,278
    Rep Power
    49

    Default

    Quote Originally Posted by DessyDago
    playable on 1.5, confirmed by myself, only in iso form (I do have the original) umd kept messing up on me but possible for some others to get it working.
    Thanks for the info - got a 1.5 myself

  5. #5
    DCEmu Rookie danknugz's Avatar
    Join Date
    Nov 2005
    Posts
    139
    Rep Power
    44

    Default

    dude, not to flame, but seriously, phonetic english sucks. it just dumbs us all down, and it makes it harder to take you seriously. you're basically typing the same ammount of text, but using words like "cuhz" instead of because is just lazy. i know im being a bitch, and i might have mistyped a few here myself, but im not doing it on purpose.sorry, im sure if i had not been up for the last 24 hours, i would not have done this. it just had to be said. man, im tired.

  6. #6
    DCEmu Old Pro SSaxdude's Avatar
    Join Date
    Dec 2005
    Location
    Suburbia, IL
    Posts
    1,928
    Rep Power
    54

    Default

    Way more isos are playable on 1.5 than UMDs. I know its piracy and all, but if you own the game there is nothing wrong with that.

  7. #7
    DCEmu Newbie
    Join Date
    Apr 2006
    Posts
    28
    Rep Power
    0

    Cool playable on 1.5

    Quote Originally Posted by DessyDago
    playable on 1.5, confirmed by myself, only in iso form (I do have the original) umd kept messing up on me but possible for some others to get it working.
    .

    Ialso have 1.5 firmware. What did you used to get this game to run the UMD???? (yes, I am a newbie)

    regards

  8. #8
    DCEmu Regular
    Join Date
    May 2005
    Location
    Japan
    Age
    41
    Posts
    452
    Rep Power
    47

    Default

    visit ps2nfo. that's the best place to get that kind of info and it really hasn't been welcome here so that's all I'll say...

    other than there is also a .ppf patch to get that game fully working (I think with no probs but I haven't bothered as I own a 1.5 AND a 2.6 :P)

  9. #9
    DCEmu Regular slayer2psp's Avatar
    Join Date
    Jun 2005
    Location
    Mexico
    Age
    46
    Posts
    440
    Rep Power
    46

    Default

    you guys like this game? so many people wanted it so i tried it out dont see whats so great about it kinda borning looks good though.and by the way only a handful of games dont work on 1.5
    outrun,neopets,fight night,mlb2k6,splintercell and fifa worldcup

  10. #10
    DCEmu Rookie PsychoSync's Avatar
    Join Date
    Dec 2005
    Posts
    186
    Rep Power
    44

    Default

    I know its probably not going to happen but, the best thing that could happen is that someone makes an app for 1.5 PSPs that can run UMDs of games that run well in ISO. And then delete (almost) all ISO loaders and ban them on most sites.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •