Valentines Day
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: LuaPlayer .20: Non-Module (All possible FW)

                  
   
  1. #1
    Won Hung Lo wraggster's Avatar
    Join Date
    Apr 2003
    Location
    Nottingham, England
    Age
    48
    Posts
    128,646
    Blog Entries
    3209
    Rep Power
    50

    psp LuaPlayer .20: Non-Module (All possible FW)

    Youresam a member of our forums has released a non module version of Lua Player, heres the details:

    Hey everyone, I was trying to get someone compile .16 of luaplayer, but I couldnt find anyone. So, I spent some time and got .16 to compile. But then I thought..hey, why not version .20?
    As many of you know, version .18 added module loading making it impossible for 2.00+ users to use LuaPlayer. The version I have made includes all of the .17-.20 features.
    So, here it is!

    NOTES:
    -I havent tested out very many features. If you find a bug, tell me.
    -Since .20 requires lua 5.1, you need to update it from the svn. See the luaplayer wiki for help.

    Download and Give Feedback Via Comments
    via youresam

  2. #2
    DCEmu Newbie
    Join Date
    Dec 2005
    Posts
    96
    Rep Power
    0

    Default

    i havent been able to load pspgolf(no script after choosing play game), laserix (freeze), vexed(no script), luamines (no script) or xbmcrmi (no script :/ )
    by using lowser
    haven't tried any others

    on my 2.01 that is

  3. #3
    DCEmu Regular luis_05's Avatar
    Join Date
    Mar 2006
    Location
    LA
    Age
    34
    Posts
    292
    Rep Power
    51

    Default

    Cannot play:

    1) Learn
    2) duckhunt v0.0
    3) Contacts
    4) netlib v1.4

    PSP FW 2.01. I used both versions for the sake of it. Got the same error : No script found!

  4. #4
    DCEmu Newbie
    Join Date
    May 2006
    Posts
    76
    Rep Power
    0

    Default

    what exactly does this mean?

    -Since .20 requires lua 5.1, you need to update it from the svn. See the luaplayer wiki for help.

  5. #5
    DCEmu Regular BALL_SAC's Avatar
    Join Date
    Mar 2006
    Location
    Teabagin, OK
    Posts
    310
    Rep Power
    50

    Default

    Does this work with 2.6 fw yet?

  6. #6
    PSP User uhoh_hotdogs's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Age
    29
    Posts
    49
    Rep Power
    0

    Default

    Quote Originally Posted by BALL_SAC
    Does this work with 2.6 fw yet?
    Yes it does, but as these people have pointed out, only marginally. Certain LUA programs and games cannot run as of yet.

  7. #7
    DCEmu Newbie dragaron's Avatar
    Join Date
    Nov 2005
    Posts
    48
    Rep Power
    0

    Default

    Thank you for doing this youresam, I REALLY appreciate it!!!

  8. #8
    DCEmu Newbie
    Join Date
    May 2006
    Posts
    76
    Rep Power
    0

    Default

    How would you be able to play games that need module loading when you have takin out the module loading? i mean what good does this do besides being able to say you have .20 , correct me if im wrong though.

  9. #9
    DCEmu Coder
    Join Date
    Feb 2006
    Posts
    14
    Rep Power
    0

    Default

    Well, the reason some games do not run is because that luaplayer .20 upgraded lua 5.0.2 to lua 5.1. See lua.org (the official lua website) for more information.

    branin: This is just luaplayer .20 WITHOUT modules. It has all the features that .20 has. The reason I took out module loading is because only 1.00 and 1.50 support them.

  10. #10
    DCEmu Newbie
    Join Date
    May 2006
    Posts
    76
    Rep Power
    0

    Default

    oh ok youresam , i see what your saying now.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •