Page 1 of 12 1234511 ... LastLast
Results 1 to 10 of 112

Thread: Tutorial - How To Make Your Nintendo Wifi USB Connector A SoftAP

                  
   
  1. #1
    The Filipino Guy kcajblue's Avatar
    Join Date
    Aug 2006
    Location
    Somewhere in California...
    Age
    23
    Posts
    4,237
    Rep Power
    96

    Default Tutorial - How To Make Your Nintendo Wifi USB Connector A SoftAP

    Ok. If you are an owner of a DS and a PSP and you only have a Nintendo Wifi USB Connector to connect to the internet with you can use this tutorial to change your Nintendo Wifi USB Connector in to a SoftAP so you can connect online with any other devices like a PSP.

    To do this you need to have this rar file:
    http://www.megaupload.com/?d=S4VLBP9A
    or you can get it from here:
    http://www.linfoxdomain.com/nintendo...i_Fullpack.rar

    You can also watch a video of me installing the Nintendo Wifi USB Connector if you dont feel like reading.
    http://www.megaupload.com/?d=31QXFFP2

    Then follow these steps:
    1)
    If you want to use the official Nintendo Wi-Fi USB Connector as a standard SoftAP make sure you have removed the Nintendo software and drivers as they will no longer be needed.
    2)
    Inside the Drivers folder of the RAR file, you will find modified Buffalo drivers. Install these drivers for the USB Connector. Then install the ASUS software (also in RAR file(eng_2371.zip)). When it prompts you to restart, select No. I have found that there is no need to.
    3)
    Now in the ASUS EXEs folder of the RAR file, extract the six EXE files in the into the ASUS folder (C:\Program Files\ASUS\WLAN Card Utilities). Make sure you overwrite the existing files.
    4)Then click Start -> All Programs -> ASUS Utility -> WLAN Card -> ASUS WLAN Control Center. You will get a dialog asking if you want to use the Windows configuration utility or the ASUS one, select the option that uses ASUS one and disables the Windows one. Then there will be a wizard. Click Cancel to close the wizard.
    5)
    Now copy the file (C:\Program Files\ASUS\WLAN Card Utilities\Driver\WinXP\AP\rt2500usb.sys) to (C:\WINDOWS\system32\drivers). Make sure you overwrite the existing file.
    6)
    Right-click on the ASUS software icon in the System Tray (bottom-right corner of screen) and select Wireless Settings. When the settings dialog opens, on the left select Config, then go to the SoftAP tab, and select Soft AP Mode. Then un-tick the Enable ICS checkbox. Then on the left click Apply. You will get a message box asking if you really want to change to SoftAP mode, click Yes. A message will come up saying something like "add the adapter to the network bridge", just ignore it and click OK. If all has gone well, there will be no error messages. Now close the ASUS Wireless Config utility or it will start conflicting when we manually set ICS.
    7)
    Now go to Control Panel -> Network Connections (this may have opened automatically opened up when you Applied the SoftAP settings). Right-click on the Network Adapter you are currently accessing your Internet through (or your internet connection icon) and open the properties for that connection. Go to the Advanced tab, and click "Allow other network users to connect through this computer's Internet connection". Then click OK. If you get an error message saying the IP address is already in use, disable the Network adapter you are trying to share then try again - be sure to enable it again afterwards. It can take a long time for ICS to be enabled so wait patiently.
    8)
    Now right-click on the Wireless Network Connection and click Properties. In the middle of the dialog there will be some protocols, select Internet Protocol (TCP/IP) and then open the properties for that. Windows would have assigned a static IP address if ICS was successfully enabled, check to make sure this IP address does not conflict with other IP addresses on your network. Also, it should be on a different subnet to the Local Area Connection (for example, my computer's IP address is 192.168.0.2, I assigned the wireless network connection the IP address of 192.168.1.1 - which is on a different subnet). If it is on the same subnet, ICS will not work correctly.
    ***9)***
    With that done, open the ASUS Wireless Config utility again. On the left select Config, in the Basic tab set a SSID. In the encryption tab, select Shared for Network Authentication and WEP for Data Encryption - I have found that this works with the DS. Now enter a WEP key. Go back to the Basic tab, and at the bottom click on Advanced, change the 54g Mode setting to 802.11b only. Click Apply on the left to save the settings.
    10)
    Now turn on your DS, play a Wi-Fi Connection game, go to the Nintendo WFC Settings, and select Manual Setup. Enter the SSID and WEP Key (both of these are case-sensitive) you entered to the ASUS Config utility before. Select No to Auto-obtain IP Address (you must do this because the Nintendo DS doesn't seem to DHCP correctly with ICS for some reason). Now give your DS an IP Address (this must be on the same subnet as the USB connector, I gave my DS the IP address: 192.168.1.2). For subnet mask enter 255.255.255.0. For gateway and primary DNS, enter the IP address of the USB connector. Now try and test connection, and if all has gone well the connection should be successful!
    11)
    Now with the ASUS Wireless Config utility, hide your SSID, and use MAC Address filtering to improve the security of your wireless access point.
    12)
    You now have an Official Nintendo Wifi USB Connector that can connect online with any other devices.
    -----------------------------------------------------------------------------------------------------------------------------
    Note 1:
    I did not make this guide. I just happened to find it and want to share it with everyone else because it helped me a lot.

    ***Note 2:***
    I use different I use different ASUS WLAN Card settings than the ones in step 9 so I can connect with the DS and PSP at the same time.
    here are my settings:

    Basic Tab
    -Network Type - Infrastructure
    -Network Name (SSID) - Hide SSID
    -Channel - 6
    -Data Rate - Fully Auto
    -PS Mode - CAM

    -----------------------------------------------------------------------------------------------------------------------------
    Encryption Tab
    -Network Authentication - Open
    -Data Encryption - Disabled

    -----------------------------------------------------------------------------------------------------------------------------
    Advanced Tab
    -RTS Threshold - 2347
    -Fragmentation Threshold - 2346
    -Preamble Mode - Long
    -Frame Bursting - Disabled
    -54g Mode - 54g Auto
    -54g Protection - Auto
    -Use Short Slot Time - Disable

    -----------------------------------------------------------------------------------------------------------------------------
    Soft AP Tab
    -Soft AP / STA Mode - Soft AP Mode

    -----------------------------------------------------------------------------------------------------------------------------
    Access Control Tab
    -Access Control Policy - Accept
    -Access Control List - (enter the MAC Addresses of your device)

  2. #2
    DCEmu Newbie
    Join Date
    Sep 2006
    Posts
    3
    Rep Power
    0

    Default

    Awesome guide, simply awesome. Although I've been mucking about with it in a desperate attempt to do something that I probably shouldn't...

    Hokay, so I've got Windows 2000. And I'm too stubborn to return my newly-gifted WiFi Dongle-thinger to the store without seeing if I can do SOMETHING to make 'er go. As it is known (and as it said on the box, too!) it's only intended for use with Windows XP. But I'm stubborn and a bit stupid... So I tried this out, everything sets up fine, except for the Internet Connection Sharing. I can get my DS to recognize the access point, but the access point can't get on the internet.

    It may be relevant that my computer connects through a router. Just a plain ol' non-wireless router. So I'm probably mis-configuring an IP somewhere along the line. Grr.

    Perhaps I'm just trying a touch too hard to do something that I can't...

  3. #3
    DCEmu Comrade pibs's Avatar
    Join Date
    Feb 2006
    Location
    califas
    Age
    24
    Posts
    1,984
    Rep Power
    39

    Default

    cool im bookmarking this so when i get my ds pretty soon i dont have to go searching.

    Thanks kcajblue

  4. #4
    The Filipino Guy kcajblue's Avatar
    Join Date
    Aug 2006
    Location
    Somewhere in California...
    Age
    23
    Posts
    4,237
    Rep Power
    96

    Default

    Quote Originally Posted by Lampdevil
    Hokay, so I've got Windows 2000. And I'm too stubborn to return my newly-gifted WiFi Dongle-thinger to the store without seeing if I can do SOMETHING to make 'er go. As it is known (and as it said on the box, too!) it's only intended for use with Windows XP. But I'm stubborn and a bit stupid... So I tried this out, everything sets up fine, except for the Internet Connection Sharing. I can get my DS to recognize the access point, but the access point can't get on the internet.

    It may be relevant that my computer connects through a router. Just a plain ol' non-wireless router. So I'm probably mis-configuring an IP somewhere along the line. Grr.

    Perhaps I'm just trying a touch too hard to do something that I can't...
    well. having windows 2000 is most likely your problem. but tell me your ASUS WLAN Card Settings and the internet Settings on your DS.

    Quote Originally Posted by pibster
    cool im bookmarking this so when i get my ds pretty soon i dont have to go searching.

    Thanks kcajblue
    no problem.

  5. #5
    The Filipino Guy kcajblue's Avatar
    Join Date
    Aug 2006
    Location
    Somewhere in California...
    Age
    23
    Posts
    4,237
    Rep Power
    96

    Default

    i updated the video on installing the Nintendo Wifi USB Connector.

  6. #6
    DCEmu Newbie
    Join Date
    Sep 2006
    Posts
    3
    Rep Power
    0

    Default

    Mmmyes, the Windows 2000 may be the heart of my problem. I've done further browsing and putzing and putzing and browsing, and I can get my DS dongle to work! My DS gets the signal. Your drivers don't seem to skip a beat. My major issue was the firewall preventing me from getting out. I've gotten it going.

    BUT... now my problem is that after a bit of working, Internet Connection Sharing goes and flips the hell out, refuses to play nice with my router, and eventually robs me of all Internet connectivity entirely. At least, until I turn ICS off and restart. I'm assuming that the IPs are conflicting horribly.

    So lesse, relevant info...

    ASUS WLAN Settings


    Encryption: Shared, WEP
    Soft AP: Soft AP Mode
    Access Control: Accept (with my DS's MAC address assigned, among other pertinent ones)
    Advanced settings:



    I will note that my Soft AP tab doesn't have all the pretty graphics and additional junk that your screenshot does. Win2k wonkiness? ICS had to be enabled manually, and the IPs had to be set. Which, speaking of IPs...

    Router's IP - 192.168.1.1

    My computer/main Ethernet card's IP - 192.168.1.101 (Although this'll tend to crap itself after ICS is on too long or I restart with ICS turned on for this connection, and it'll tend to become something random that shows no relation to anything anywhere.)

    WiFi's assigned IP - 192.168.2.1
    DS's assigned IP - 192.168.2.2

    If there's some other specific info you need, feel free to ask and I'll dig it up. I've narrowed the issue down to some kind of insane conflict with how ICS works and what my router expects. There's no problem at all making the WiFi itself work. It's all peachy. I'm hoping that the way Win2k handles ICS isn't the reason the dongle wasn't meant to be used with this OS.

  7. #7
    The Filipino Guy kcajblue's Avatar
    Join Date
    Aug 2006
    Location
    Somewhere in California...
    Age
    23
    Posts
    4,237
    Rep Power
    96

    Default

    try changing your WiFi's assigned IP & your DS's assigned IP to something thats not 192.168.x.x

  8. #8
    DCEmu Newbie
    Join Date
    Sep 2006
    Posts
    3
    Rep Power
    0

    Default

    Quote Originally Posted by kcajblue
    try changing your WiFi's assigned IP & your DS's assigned IP to something thats not 192.168.x.x
    Hrmm, there's a thought. So I could bump 'em both to 193.168.x.x instead or something, and it'd still be functional?

    Let's give 'er a go!

    ....and so far, so good! No bizzare problems as of yet. Thanks for the help.

  9. #9
    The Filipino Guy kcajblue's Avatar
    Join Date
    Aug 2006
    Location
    Somewhere in California...
    Age
    23
    Posts
    4,237
    Rep Power
    96

    Default

    no problem. your happiness is my reward. lol

  10. #10

    Default

    I don't understand. I download the rar and extracted it. I uninstalled the nintendo program and all that. Then when I put the wifi connector in my usb drive I got the new harddrive message thingy, but I didn't get one for the buffalo drivers (which you have to install to the connecter?) in the video it does the hardware installer for the buffalo thing. How do I install that to my wifi connector?


    EDIT: ok i figured that out. Now my problem is when I go to the ASUS Wlan Wireless Settings the Enable ICS option is disabled so I cant uncheck it. I'm not sure what to do.

    EDIT2: Solved that problem myself too :P. Now when I try to allow other connections in on my main connection I get the ip in use error. But it still comes up even if I disable the other one. What do I do? I am under a router if that makes any difference.

Page 1 of 12 1234511 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •