Page 1 of 9 12345 ... LastLast
Results 1 to 10 of 81

Thread: [GUIDE/RELEASE] 3.00 Full Hybrid Devhook (2.71 kernel)

                  
   
  1. #1
    DCEmu Old Pro kando's Avatar
    Join Date
    Jul 2006
    Posts
    1,050
    Rep Power
    49

    psp [GUIDE/RELEASE] 3.00 Full Hybrid Devhook (2.71 kernel)

    Team FWI (kando, LordSturm, birdman, JamesBDX)

    TEAM FWI - birdman PROUDLY PRESENTS..........

    3.0F HYBRID DEVHOOK!

    CURRENTLY WORKS:
    iso's can be run
    hen-d programs work
    umd's work
    camera works
    visualizer works
    in game - wifi

    CURRENTLY DOESNT WORK:
    Web browser
    xmb - wifi
    ps3 remote connection
    (most of these are now known not to work because we are still useing 2.71 kernel, if we can hack msreboot.bin we can get 3.0 kernel)

    Nessassary matirials:
    • a psp with se-c (no other version will work)
    • the 3.0 psardumper/decrypter (attacheed below)
    • the 3.0 psar file
    • the basic needs file (attached below)
    • a hex editor


    - create a 3.0 dump useing psardumper.

    - you will then have a F0 file in the root of your memory stick.
    take the VSH, DIC, KD, FONT, DATA folders out of the F0 folder and put them in the root of your memorystick.

    - useing a hex editor (not notepad) redirect all the lines pointing to flash0:/ to fatms0:/ in the following files:

    - i used xvi32 a free hex editor, in it there is a simple replace function replace: flash with fatms

    Files to fix (all are located in vsh/modules) (all are prx's)
    • camera_plugin
    • common_util
    • dialogmain
    • game_plugin
    • htmlviewer_plugin
    • htmlviewer_utility
    • lftv_main_plugin
    • lftv_plugin
    • libfont_hv
    • msvideo_main_plugin
    • msvideo_plugin
    • music_main_plugin
    • music_plugin
    • netconf_plugin
    • netplay_client_plugin
    • opening_plugin
    • paf
    • pafmini
    • photo_plugin
    • premo_plugin
    • rss_subscriber
    • sysconf_plugin
    • video_main_plugin
    • video_plugin
    • vshmain
      • For vshmain do the replace command, then do ctrl+f and search for index.dat, replace its fatms0:/ with flash0:/ if you dont you will get a RSoD.


    one file in kd - cert_loader.prx must also have flash replaced with fatms.


    once this is done, load up the devhook i included, select 271F

    BE SURE THE DEVHOOK IS BEING LOADED FROM 2.71 KERNEL!


    - dont try loading system settings or power settings, power settings will freeze your psp and system settings will give you an internal error


    to-do:
    flash1 emulation? (if you have a 3.0 flash1 pm me)

    CREDITS GO TO:
    TEAM FWI (firmware investigators)
    ----------------------------------
    Birdman - 3.0 hybrid devhook maker
    Kando - 3.0 hybrid flash maker - initial discoveries
    JamesBDX - 3.0 hybrid flash maker
    Lordsturm - original idealist


    credits also go to:
    booster - for devhook (need i say more?)

    dark_alex - for all the amazeing things he has done, dark_alex is one of the most infulencial people to the psp scene, withount him, i dont even want to think of where we would be.(in this hack, we his used se-c and 271F modules)

    TEAM FWI SUPPORTS DARK_ALEX. WHEREVER HE MAY GO

    Download and Give Feedback Via Comments

  2. #2
    DCEmu Legend gunntims0103's Avatar
    Join Date
    May 2006
    Location
    Brentwood, NY
    Age
    27
    Posts
    2,976
    Rep Power
    87

    Default

    nice release kando

  3. #3
    DCEmu Newsposter Vega's Avatar
    Join Date
    Mar 2006
    Location
    N.Ireland
    Age
    36
    Posts
    1,063
    Rep Power
    51

    Default

    Very nice indeed

    Click on the sig above to visit The Playground

  4. #4

    Default

    sweet i might give this a try later on tonight thanks for the release and keep up the great work

  5. #5
    Fidei Defensor Basil Zero's Avatar
    Join Date
    May 2006
    Location
    Omni
    Posts
    1,674
    Rep Power
    54

    Default

    does this work on 1.5?

  6. #6
    DCEmu Pro
    Join Date
    Aug 2006
    Location
    Norway
    Age
    26
    Posts
    902
    Rep Power
    51

    Default

    Wow, this is so amazing.
    I really hope you can manage to hack the rest of the files so we can take full advantage of this.

    Basil Zero: I'm not sure, but I see it unlikely as you need to load from 2.71 kernel, so I guess you need 2.71 SE-C.

    Keep up the fantastic work, Team FWI!

  7. #7
    DCEmu Regular Jonesyxxiv's Avatar
    Join Date
    Mar 2006
    Posts
    276
    Rep Power
    47

    Default

    Sounds like a lot of work to do.

    Edit: so this will be able to play MGS portable ops?

  8. #8
    DCEmu Regular Kvonx's Avatar
    Join Date
    Apr 2006
    Location
    MIA....FLORIDA!!
    Age
    29
    Posts
    289
    Rep Power
    46

    Default

    this sounds hard to install, cant someone make an installer!!!! please

  9. #9

    Default

    Ok, I've started to replace flash with fatms, but when I use the automatic replace option it puts boxes in between the letters. I don't have experience with hex editing, so will this affect anything?

    and thanks for the release

  10. #10
    DCEmu Old Pro mavsman4457's Avatar
    Join Date
    Mar 2006
    Location
    East Coast, USA
    Posts
    1,278
    Rep Power
    51

    Default

    This is awesome but sadly the only reason that I really want 3.00 is for remote play and right now that does not work .

Page 1 of 9 12345 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •