Page 1 of 22 1234511 ... LastLast
Results 1 to 10 of 215

Thread: Devhook v0.51 released - PSP Firmware v3.01 Emulation Compatible

                  
   
  1. #1
    PSP User
    Join Date
    Feb 2006
    Age
    30
    Posts
    166
    Rep Power
    44

    psp Devhook v0.51 released - PSP Firmware v3.01 Emulation Compatible

    Booster has released a new version of Devhook with support for V3.01 firmware meaning all firmware is now covered by Devhook.

    More Info via Translation Thanks Grimm

    This is a driver and tool to run new FW versions on a FW 1.50 PSP.

    A few known bugs from 0.50 have been fixed, but debugging is still not complete, and thus the software continues to be in a testing phase.

    The degree of stability is still unknown. Please test it on your own and refer to different people's test reports.

    Known Issues
    -----------------------------

    With the change to the API, previous version's launchers, vshex, etc. do not work.

    vshex (the settings display on top of the XMB) occasionally has issues.

    When a UMD game is launched from the XMD, the startup screen can sometimes hang.

    There are times when you cannot return from a game to the XMB.

    V0.50.0000 -> V0.51.0000 Changelog
    -----------------------------

    Loading bugs from the memory stick have been fixed > The web browser and the rest of the XMB

    Compatible with FW 3.01

    The clock setting bug in FW >=2.80 has been fixed.

    There's no need to replace audio.prx in FW >=2.80

    It can coexist with DH 0.46

    The launcher has been changed, scripting has been improved and it is compatible with mok's fbmprint system and multi language support.

    Leaving DEVHOOK from the XMB has been reimplemented (still being worked on)

    Regarding the execution of FW 2.82 (3.01,2.80,2.71)
    -----------------------------

    As of ver.0.50.0000, the supported firmware's are only 2.71, 2.82, and 3.00.

    1.50's No UMD mode has been removed, however other bits of code haven't yet been confirmed and still remain.

    If you have a need for 1.50-2.60, I request that you try them individually and decide on whether and how they run. (translator's note: I could use some help on this sentence, it seems kind of weird...I guess the implication is that old firmware's may still be able to run, but are hit or miss because they aren't actively supported)

    There is a slight risk associated with installing files to flash1, but this is highly recommended.
     
    If files are not installed to flash1 on > FW 2.71, there's a risk that random files will be destroyed when certain actions are taken on the XMB. Depending on the crosslinking, unrelated files may be destroyed, so please be prepared for any file to be lost when using it.

    You will know if files have been destroyed if you connect to a PC via USB and run checkdisk.

    -----------------------------
    todo
    -----------------------------

    Launcher menu scripting language
    The scripting language is currently a fairly half-baked, simple language; I'd like to make it C-like.

    Sorry for the slow and piecemeal translation. The todo list is the same as the last release, except that 3.01 is now supported.

    Download and Give Feedback Via Comments

    DCEmu is only Interested in the UMD Aspects of this release, No ISO Discussion whatsoever

  2. #2
    DCEmu Coder splodger15's Avatar
    Join Date
    Jun 2006
    Location
    London
    Age
    26
    Posts
    4,130
    Rep Power
    69

    Default

    Nice work booster

    PSN ID: splodger15

  3. #3
    PSP User Emeriastone's Avatar
    Join Date
    Feb 2006
    Location
    MO, USA
    Posts
    612
    Rep Power
    46

    Default

    Yeeeees!!! Triumph!!

  4. #4
    King of killed the_eternal_dark's Avatar
    Join Date
    Dec 2005
    Posts
    1,534
    Rep Power
    54

    Default

    That was quick. Great job booster!

  5. #5
    DCEmu Legend
    Join Date
    Sep 2006
    Location
    USA
    Posts
    2,152
    Rep Power
    52

    psp Metal Gear Solid: Portable Ops - Here I come!

    Yes, Yes, and HELL YEAH!

    This almost certainly seals the deal for being able to play MGS: PO on a 1.50 PSP. I wonder how this will work with the SONY download service and PS1 emulation.

    Awesome stuff Booster! I figured DevHook would come through for 3.0* firmware emulation, but to have it so soon after the firmware was just released is beyond spectacular.

  6. #6
    Extraterrestrial ExcruciationX's Avatar
    Join Date
    Feb 2006
    Location
    Serpo, Zeta Reticuli
    Posts
    3,628
    Rep Power
    97

    Default

    AWESOME (Sorry for caps)! Great Job, Booster!

  7. #7
    DCEmu Legend
    Join Date
    Sep 2005
    Posts
    2,355
    Rep Power
    56

    Default

    I think I'll wait until it becomes more stable and less problematic.

  8. #8
    DCEmu Regular
    Join Date
    Apr 2005
    Posts
    392
    Rep Power
    48

    Default

    Great job booster

  9. #9
    DCEmu Newbie
    Join Date
    Oct 2006
    Posts
    9
    Rep Power
    0

    Default

    thanks man..great job..this works like a charm and still homebrew compartible...now am ready for some metal gear solid action..wan

  10. #10
    DCEmu Pro mikebeaver's Avatar
    Join Date
    Oct 2006
    Location
    Ipswich-England
    Age
    38
    Posts
    636
    Rep Power
    44

    Default

    Super job booster, so much for 3.01's added security.
    Congrats on a speedy bit of work.

Page 1 of 22 1234511 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •