Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Probably hacked psp, help me!

                  
   
  1. #1
    DCEmu Newbie
    Join Date
    Oct 2007
    Posts
    4
    Rep Power
    0

    Default Probably hacked psp, help me!

    The thing is, I bought my psp for about a year ago. I asked a friend to help me with it so that I could play snes-games on it. He helped me.

    These days I rarely use it, but Final Fantasy Tactics are out this month and I want to play it. When I tried to start the game it didn't work, at all. I have tried lots of things but I'm not very technical though...

    My friend updated it to 7.50 and I think that that is the problem...But I don't know what to do!

    Can anybody help me with this problem?

  2. #2
    DCEmu Coder splodger15's Avatar
    Join Date
    Jun 2006
    Location
    London
    Age
    29
    Posts
    4,130
    Rep Power
    79

    Default

    1)No such thing as 7.50 go system settings then system information and check properly

    PSN ID: splodger15

  3. #3
    PSP Coder -Xandu-'s Avatar
    Join Date
    Jan 2007
    Posts
    1,036
    Rep Power
    66

    Default

    7.50 was a firmware spoof version used by SXT Version Changer. So it's only a version change.

  4. #4
    DCEmu Newbie
    Join Date
    Oct 2007
    Posts
    4
    Rep Power
    0

    Default

    I have checked the system settings and after system software it says Version 7.50

  5. #5
    DCEmu Newbie
    Join Date
    Oct 2007
    Posts
    4
    Rep Power
    0

    Default

    How do I change the version then? I don't know anything about these things...

  6. #6
    PSP Coder -Xandu-'s Avatar
    Join Date
    Jan 2007
    Posts
    1,036
    Rep Power
    66

    Default

    Re-download the SXT Version Changer or use any of the other version changers out there. Then you can restore it back to 1.50. After that you can upgrade to the latest CFW (3.71-2 M33) and UMD games will be fully compatible.

  7. #7
    DCEmu Newbie
    Join Date
    Apr 2007
    Posts
    18
    Rep Power
    0

    Default

    wat version does final fantasy tactics require?

  8. #8
    DCEmu Newbie
    Join Date
    Oct 2007
    Posts
    4
    Rep Power
    0

    Default

    I shall try that, thank you!

  9. #9
    DCEmu Legend DarthPaul's Avatar
    Join Date
    Apr 2006
    Location
    Puerto Rico
    Age
    30
    Posts
    2,734
    Rep Power
    74

    Default

    Lmao 7.50! :rofl:

  10. #10

    Default

    Quote Originally Posted by DarthPaul View Post
    Lmao 7.50! :rofl:
    What's funny about it?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •