Results 1 to 4 of 4

Thread: Updating SuperCard firmware

                  
   
  1. #1
    DCEmu Rookie CoinCollector's Avatar
    Join Date
    Aug 2007
    Location
    Vancouver, WA
    Posts
    121
    Rep Power
    0

    Default Updating SuperCard firmware

    I just purchased a Supercard SD and Superkey for my DS. The first thing I tried was playing NES ROMs. SuperCard is supposed to be able to play them without any additional software. It worked great. But then I noticed it was an outdated version of PocketNES. I thought maybe it would go to the latest version if I updated the SuperCard firmware. I had version 1.62, and I updated it to 1.83. Then I loaded an NES game to see if PocketNES was updated, and it wouldn't load! It would just do the GameBoy animation then go to a white, blank screen!

    So I downgraded to 1.7, one version higher than what I originally had. The NES games worked again. Then I tried 1.81, then 1.83 again, and neither played NES games. I'm not sure what the problem is. I don't NEED the latest version of PocketNES or the firmware installed; everything works fine without them, but I would like everything to be updated. It's just nice to have them updated, you know? To have the latest software.

  2. #2

    Default

    well oviously u want to keep the lower one because it actually plays the games. but heres a question, are updating the cards firmware or the emulators version?

  3. #3
    DCEmu Old Pro DanTheManMS's Avatar
    Join Date
    Oct 2006
    Posts
    1,946
    Rep Power
    67

    Default

    It's a common problem, and luckily we figured out why it happens. Skipping firmware 1.80 when updating causes the built-in emulators to break. Downgrading to 1.7 and then going to 1.80 before 1.81 and 1.83 prevents them from breaking. However, because 1.80 broke most homebrew, it's no longer available from the Supercard website. I have copies though. Downgrade to 1.7 and then get this file (first is for Supercard CF, second is Supercard Lite, third is Supercard SD/miniSD):

    http://dannysied.googlepages.com/SCCF_UPGRADEv1.8.rar
    http://dannysied.googlepages.com/SCL...D_1.80_eng.rar
    http://dannysied.googlepages.com/SCSD_UPGRADEv1.8.rar

    Since it's a *.scu file, copy it to the root of your card and boot up to upgrade.

    Then install 1.81 and then 1.83 in order. Hope it helps.

    EDIT: Also make sure you upgrade the Supercard software to the latest version once your firmware is upgraded to 1.83. You may need to use it for the new firmware.

  4. #4
    DCEmu Rookie CoinCollector's Avatar
    Join Date
    Aug 2007
    Location
    Vancouver, WA
    Posts
    121
    Rep Power
    0

    Default

    Wow, it worked! Now I'm at version 1.83 and still playing NES games! Thanks, Dan!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •